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i-Tree Eco  Random Plots Workbook:                    No Stratification 
 
These instructions help users of all skill levels create random UFORE sample points and their 
associated UFORE-required data within a defined UFORE project area.  NO stratification of 
sample plots is performed.  ESRI ArcGIS v9.x software is used.  
 

These instructions are composed of four basic steps: 
1. Project Area Data Preparation 
2. Sample Plot Generation 
3. Create UFORE-ready Output 

 
These instructions result in these items: 

 Projected Area-of-Interest map layer composed of a single (multi-part) POLYGON. 
 Random Sample Plots POINT map layer with UFORE-required fields added and 

populated. 
 Sample Plot Areas POLYGON map layer. 
 UFORE Strata Area report text file. 
 UFORE Plot List report text file. 
 UFORE PRJ file. 

 

Tips 
 These instructions require use of a few simple i-Tree tools within the iTree.mxd ArcMap 

project file that can be downloaded from the i-Tree website. 

 Advanced GIS users: primarily follow the bulleted Overviews with attention given to the 
Detailed Instructions in areas such as field names and types. 

 Obtain projection/coordinate system and map unit information from the map data 
provider. 

 Final map units must be either Feet or Meters. 

 Area-of-Interest (AOI) examples are large polygons such as: city boundary, park areas, 
or a management zone(s).  

 ESRI Shapefiles, Coverages, or Geodatabases can be used; shapefiles are easiest. 

 Practice good file management using folders to hold copies of original data, folders to 
hold output, employ logical file naming, etc. 

 Save the iTree.mxd project periodically through all steps. 

 Actions in red represent standard ArcGIS operations. 

 Actions in green represent iTree.mxd toolbar operations. 
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Project Area Data Preparation 
 
 
Overview: 

 Obtain a GIS map layer representing the Area-of-Interest (AOI) polygon(s) for your 
project area. 

 Launch the ArcMap application of ArcGIS at the ArcView, ArcEditor, or ArcInfo level. 
 Open and  ‘Save As’  the  iTree.mxd  project with a new user-defined name at a user-

defined location. 
 Load the Area-of-Interest (AOI) map layer into the view. 
 Define the projection/coordinate system of the AOI. 
 Reproject the AOI to a system using feet or meters if needed. 
 Dissolve the AOI into a single polygon (single,multi-part polygon if more than one 

polygon). 
 Add UFORE-required fields and Calculate appropriate values for them 

 
Results: 

 Projected AOI map layer composed of a single (possibly multi-part) polygon with 
UFORE-required fields added and populated. 

 
 
 
Detailed Instructions: 
 

1. Obtain an Area-of-Interest (AOI) polygon from your GIS Department or an online 
resource such as ESRI’s Geography Network (http://www.geographynetwork.com/). 

 

2. Launch ESRI’s ArcMap application at the ArcView (or ArcEditor or ArcInfo) level.  

 

3. Use the open button  to browse for the iTree.mxd downloaded from the i-Tree site. 

a. The iTree.mxd project file contains a custom toolbar for random sample 
generation and UFORE report output: 

 
 

4. Save a copy of the iTree.mxd project with a new name at a new location via the 
File>Save As menu. 

 

5. Open ArcToolbox  if necessary. 



i-Tree Eco Random Plots Workbook:           No Stratification 

 

 3

6. Use the Add Data button  to navigate to and load the AOI polygon map layer to the 
current view.  

a. An “Unknown Spatial Reference” message may appear; click OK to move past it. 

 
 

7. Use ArcToolbox to Define the Projection of the AOI map layer per your data 
provider’s specifications (If a projection is already defined, skip to Step 8 ): 

a. Navigate to ArcToolbox>Data Management Tools>Projections and 
Transformations>Define Projection 

b. Fill out the Define Projection form: 

 
i. Input Dataset:  choose the AOI map layer from the drop down. 

ii. Coordinate System: click the properties button at right and use the 
ensuing “Spatial Reference Properties” dialog window to navigate to the 
proper coordinate system via the Select button. 

 

Proper coordinate 
system is 

determined by 
your data provider.
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8. If needed, use ArcToolbox to Reproject your AOI map layer to a system using feet or 
meters: 

a. This system would ideally be one already in use by your organization or a 
commonly used system such as State Plane or UTM in the United States. 

b. Navigate to ArcToolbox>Data Management Tools>Projections and 
Transformations>Feature>Project 

c. Fill out the ensuing Project form: 

 

i. Input Dataset:  choose the AOI map layer from the drop down. 

ii. Input Coordinate System: Based on Step 7 above, this should be grayed 
out with the previously defined projection system. 

iii. Output Dataset or Feature Class: use the browse button  to locate 
a suitable location and filename for the resulting map layer. 

iv. Output Coordinate System: click the properties button at right and 
use the ensuing “Spatial Reference Properties” dialog window to 
navigate to the proper coordinate system via the Select button. 
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v. Geographic Transformation: while marked as “Optional”, select the first 

choice in the drop down if prompted with an “Undefined Geographic 
Transformation” message. 

vi. Click OK. 

 

9. If your AOI has more than one polygon, use ArcToolbox to Dissolve the them: 

a. Navigate to ArcToolbox>Data Management Tools>Generalization>Dissolve 

b. Fill out the ensuing Dissolve form: 

 

i. Input Features: choose the projected AOI map layer from the drop 
down list. 

Choose a 
coordinate system 
employing either 

feet or meters.
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ii. Output Feature Class: use the browse button  to locate a suitable 
location and filename for the resulting map layer. 

iii. Dissolve_Field(s): check the data field whose attribute value unifies the 
AOI.  Example: a “Name” field containing the city name of an AOI, even 
across physically separate city sections. 

iv. Statistics Field(s) : Leave blank. 

v. Create Multipart Features: ensure this option is checked. 

vi. Click OK 

 

10. Use ArcToolbox to Add UFORE-required fields to the projected, dissolved,  AOI map 
layer: 

a. Navigate to ArcToolbox>Data Management Tools>Fields>Add Field 

b. Fill out the ensuing Add Field form: 

 
i. Input Table: select the AOI map layer from the dropdown list. 

ii. Field Name: Enter “Strat_ID”  (no quotes) 

iii. Field Type: Select LONG  from the dropdown list 

iv. Field Precision: Skip this entry 

v. Field Scale: Skip this entry 

vi. Field Length: Skip this entry 

vii. Field Alias: Skip this entry 

viii. Field IsNullable: Skip this entry 

For experienced 
users, fields could 
be added via the 

ArcMap table view 
as well. 
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ix. Field IsRequired: Skip this entry 

x. Field Domain: Skip this entry 

xi. Click OK 

c. Repeat as follows for these THREE additional fields: 

i. Field Name: “Strata”  (no quotes) 

Field Type: TEXT  

ii. Field Name: “Strat_Area”  (no quotes) 

Field Type: DOUBLE   

iii. Field Name: “No_Plots1”  (no quotes) 

Field Type: LONG  

 

11. Use ArcToolbox to Calculate values for the UFORE-specific fields added to the 
projected, dissolved, AOI map layer: 

a. Navigate to ArcToolbox>Data Management Tools>Fields>Calculate Field 

b. Fill out the ensuing Calculate Field form: 

 

i. Input Table: select the AOI polygon map layer from the dropdown list. 

ii. Field Name: Select “Strat_ID” 

iii. Expression: enter this expression:   1  

iv. Expression Type: Skip this entry (default is typically VB) 

v. Code Block: Skip the entry 

For experienced 
users, the Field 

Calculator could 
be used via the 
ArcMap table 

view. 
 

Also, later 
versions of 

ArcGIS have a 
“Calculate 

Geometry” option 
available via a 

right-click on the 
field name in the 

table. 
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vi. Click OK 

c. Repeat for the “Strata” field: 

i. Input Table: select the AOI polygon map layer from the dropdown list. 

ii. Field Name: Select “Strata” 

iii. Expression: enter this expression, INCLUDING quotes:  “Single Strata”  

d. Repeat for the “Strat_Area” field: 

i. Input Table: select the AOI polygon map layer from the dropdown list. 

ii. Field Name: Select “Strat_Area” 

iii. Expression: enter this expression: Output  

iv. Expression Type: VB 

v. Code Block: enter this code  (hint – copy and paste from here):  

Dim Output as double 
Dim pArea as Iarea 
Set pArea = [shape] 
Output = pArea.area 
 

e. Repeat for the “No_Plots1” field: 

i. Input Table: select the AOI polygon map layer from the dropdown list. 

ii. Field Name: Select “No_Plots1” 

iii. Expression: enter the equivalent of this expression:   

<< the number of random sample plots to be generated >>  

(hint: this MUST match the number of sample plots to be 
generated below) 

12. Final results:  

a. Area-of-Interest (AOI) POLYGON map layer with UFORE-required fields added 
and populated. 

i. Verify AOI map layer is loaded into the map view. (It may be necessary 
to right-click the new AOI layer and select “Zoom to Layer”. ) 

ii. It should have one record present in its table. (Right-click the new AOI 
layer name in the map layers list, and choose “Open Attribute Table”) 

 

 

The AOI polygon 
map layer is now 
ready to be used 

for  
Plot Generation. 

 
Instructions 

continue below.
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Sample Plot Generation  
 
 
Overview: 

 Run the Random Plots tool from the i-Tree toolbar. 
 Add Fields to the Random Plots data 
 Calculate field values for Random Plots data 
 Buffer the Random Plots point data to form plot areas 

 
Results: 

 Random Sample Plots POINT map layer in ESRI GIS format with UFORE-required fields 
added and populated. 

 Sample Plot Areas POLYGON map layer in ESRI GIS format. 
 
 
 
Detailed Instructions: 
 

1. Click to select the AOI polygon layer in the map layers list and click the Random Plots 

Tool in the i-Tree toolbar. 

a. Enter the desired number of sample points in the ensuing Random Point 
Generator dialog: 

 
b. Click Compute and then select a location and filename for the sample plots point 

map layer to be created. 

c. Click Close to exit the Random Point Generator dialog. 

 

2. Use ArcToolbox to Add UFORE-required fields to the newly created sample plots 
point map layer: 

a. Navigate to ArcToolbox>Data Management Tools>Fields>Add Field 

b. Fill out the ensuing Add Field form: 

If post-
stratification is to 

be performed, 
a minimum of 20 

plots is 
recommended per 

stratum. 
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i. Input Table: select the sample plots point map layer from the dropdown 

list. 

ii. Field Name: Enter “ID”  (no quotes) 

iii. Field Type: Select LONG from the dropdown list 

iv. Field Precision: Skip this entry 

v. Field Scale: Skip this entry 

vi. Field Length: Skip this entry 

vii. Field Alias: Skip this entry 

viii. Field IsNullable: Skip this entry 

ix. Field IsRequired: Skip this entry 

x. Field Domain: Skip this entry 

xi. Click OK 

c. Repeat as follows for these additional FIVE fields: 

i. Field Name: “LCCode”  (no quotes) 

Field Type: SHORT  

ii. Field Name: “X_Coord” (no quotes) 

Field Type: DOUBLE 

iii. Field Name: “Y_Coord”  (no quotes) 

Field Type: DOUBLE 

For experienced 
users, fields could  
be added via the 

ArcMap table view 
as well. 
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iv. Field Name: “LCType”  (no quotes) 

Field Type: TEXT 

v. Field Name: “MapUnits”  (no quotes) 

Field Type: TEXT 

 

3. Use ArcToolbox to Calculate values for the UFORE-specific fields added to the sample 
plots point map layer in step 2: 

a. Navigate to ArcToolbox>Data Management Tools>Fields>Calculate Field 

b. Fill out the ensuing Calculate Field form: 

 

i. Input Table: select the sample plots point map layer from the dropdown 
list. 

ii. Field Name: Select “ID” 

iii. Expression: enter this expression:  [FID]+1  

iv. Expression Type: Skip this entry 

v. Code Block: Skip the entry 

vi. Click OK 

c. Repeat for the “LCCode” field: 

i. Input Table: select the sample plots point map layer from the dropdown 
list. 

ii. Field Name: Select “LCCode” 

For experienced 
users, the Field 

Calculator could 
be used via the 
ArcMap table 

view.
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iii. Expression: enter this expression:  1 

d. Repeat for the “X_Coord” field: 

i. Input Table: select the sample plots point map layer from the dropdown 
list. 

ii. Field Name: Select “X_Coord” 

iii. Expression: enter this expression:  Output  

iv. Expression Type: VB 

v. Code Block: enter this code  (hint – copy and paste from here): 

Dim Output As Double 
Dim pPoint As IPoint 
Set pPoint = [Shape] 
Output = pPoint.X 

e. Repeat for the “Y_Coord” field: 

i. Input Table: select the sample plots point map layer from the dropdown 
list. 

ii. Field Name: Select “Y_Coord” 

iii. Expression: enter this expression:  Output  

iv. Expression Type: VB 

v. Code Block: enter this code (hint – copy and paste from here): 

Dim Output As Double 
Dim pPoint As IPoint 
Set pPoint = [Shape] 
Output = pPoint.Y 

f. Repeat for the “LCType” field: 

i. Input Table: select the sample plots point map layer from the dropdown 
list. 

ii. Field Name: Select “LCType” 

iii. Expression: enter this expression, INCLUDING quotes:  “Single Strata”  

g. Repeat for the “MapUnits” field: 

i. Input Table: select the sample plots point map layer from the dropdown 
list. 

ii. Field Name: Select “MapUnits” 

iii. Expression: enter one of these expressions, INCLUDING quotes: 

“Foot_US” if map units are feet or 

“Meters” if map units are meters 

 

Map units are 
determined by 

your data provider. 
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h. Verify the attributes have been correctly modified in the sample plots point map 
layer: 

i. Right-click the new, sample plots point map layer in the map layers list, 
and choose “Open Attribute Table”. 

ii. Scan through the fields and their values to verify they are correct. 

iii. Note that no projection system is assigned to the plots layer. If desired, it 
can be defined using steps similar to those for defining the AOI projection 
system above. 

 

4. Use ArcToolbox to Buffer the sample plots point map layer: 

a. Navigate to ArcToolbox>Analysis Tools> Proximity>Buffer 

b. Fill out the ensuing Buffer form: 

 

i. Input Features: select the sample plots point map layer from the 
dropdown list. 

ii. Output Feature Class: use the browse button  to locate a suitable 
location and filename for the resulting map layer. 

iii. Distance: Ensure that “Linear unit” is selected and the appropriate units 
are chosen. Enter the desired Distance value from this list: 

Map units in FEET: 
1. 1/5 acre plot:  Enter: 52.66 
2. 1/10 acre plot:  Enter: 37.24 
3. 1/20 acre plot:  Enter: 26.33 
4. 1/100 acre plot:  Enter: 11.78 
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Map units in METERS: 
1. 1/5 hectare plot:  Enter: 25.23 
2. 1/10 hectare plot:  Enter: 17.84 
3. 1/20 hectare plot:  Enter: 12.62 
4. 1/100 hectare plot: Enter: 5.64 

iv. Side Type: Skip this entry 

v. End_Type: Skip this entry 

vi. Dissolve Type: Skip this entry 

vii. Dissolve Field(s): Skip this entry 

viii. Click OK 

c. The buffered sample points layer is added to the map view automatically; zoom 
in to examine individual plot areas. 

5. Final Results 

a. Sample Plots POINT map layer 

i. User-defined number of plots randomly spread throughout AOI 

ii. UFORE-required fields added and populated 

b. Sample Plot Areas POLYGON map layer 
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Create UFORE-ready Output 
 
 
Overview: 

 Run the UFORE Strata Area Report tool 
 Run the UFORE Plot List Report tool 

 
Results: 

 UFORE Strata Area report text file 
 UFORE Plot List report text file 
 UFORE PRJ file 

 
 

1. Select the sample plots point map layer in the map layers list and click the UFORE 

Plot Report tool  in the i-Tree toolbar to create the UFORE Plot 
Report: 

a. Answer the following question to confirm the map units of the sample plots point 
map layer. 

     

b. In the ensuing dialog window, select a location and filename for the UFORE Plot 
Report. 

i. Report is finished with the following prompt: 

 
 

c. If a field is missing, or incorrectly named, an error message will appear: 

 

i. Even though the output will be completed, it is necessary to revisit the 
preceding instructions to correct the mistake. 

ii. Repeat this step to output a new, corrected UFORE Plot Report. 
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2. Select the AOI polygon layer in the map layers list and click the UFORE Strata Report 

tool  in the i-Tree toolbar to create the UFORE Strata Report: 

a. Answer the following question to confirm the map units of the sample plots point 
map layer. 

      
 

b. In the ensuing dialog window, select a location and filename for the UFORE 
Strata Report. 

 

c. Report is finished with the following prompt: 

 
 

d. If a field is missing, or mis-named, an error message will appear: 

 

i. Even though the output will be completed, it is necessary to revisit the 
preceding instructions to correct the mistake. 

ii. Repeat this step to output a new, corrected UFORE Strata Report. 

3. Final Results: 

a. UFORE Reports 

i. Plot Listing 

ii. Strata Listing 

iii. PRJ file (automatically created in the Define Projection/Reprojection steps 
above as part of the AOI Shapefile) 


